Universe/derivations/universe.nix

36 lines
931 B
Nix

# Universe - The big bang to my universe
#
# Copyright (c) 2023-2024 Sameer Rahmani <lxsameer@gnu.org>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, version 2.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
{
lib,
stdenv,
}:
stdenv.mkDerivation (final: {
pname = "universe";
version = "23.11.0.0";
src = ../.;
doUnpack = false;
doCheck = false;
doInstall = false;
buildPhase = ''
mkdir -p $out/
cp -rv ${final.src}/* $out/
'';
})